Community Support


Please use this page to ask questions not included in the FAQ for the All in One – System Rescue Toolkit Technician or Lite versions.  I cannot guarantee that I will answer all questions in a timely manner, but as this toolkit grows, we may be able to have more folks chime in with answers.

  • This is a toolkit Q&A support, not general tech support.  If you need help beyond what the toolkit can provide, please seek computer help from a professional technician in your area.
  • Please do not link to or recommend other tools outside of this toolkit when answering questions, including commands built into Windows.  If the toolkit does not provide a solution, please simply say so.
  • Feel free to suggest additions to the toolkit and I will take them into consideration.  Please make sure that tools you suggest support distribution and commercial use or they will be immediately rejected.

210 Replies to “Community Support”

  1. after over 4 hours im stuck on the repair explorer symbols repair… do i need to wait until its done like its taking forever

  2. Hi, my windows has been crashed.
    There is no mbr or gtp details marking to recognise my C: drive as windows installation.
    Tried fixboot, bixmbr, rebuild mbr.. non works.
    The system ends up in blue screen.
    System cannot find restore points or last upgrades to restore.
    Can’t even boot into safemodes.

    I tried your iso but how & where to run aio Executables where I even can not boot into one.

    In EFI your disk doesn’t boot into aio-rescue mini windows PE.. & lubuntu doesn’t recognise mbr.

    1. Backup Bitlocker Key – if you still can – disable UEFI and secure boot and set up in BIOS to boot from a USB device / Stick. Boot with AIO USB device. Try it that way.

  3. Hey. My mouse and keyboard stop working when I boot into lubuntu. Any idea how to fix it?

    Same as Bruce back in 2018…

    I see during booting a ton of USB5/4 device descriptor & read/64 error -32 lines stating unable to enumerate, not accepting address xxx

  4. Ok, I’ve got the fixit software working and it looks as if it is doing something. The processors are humming along. My question is how long does it take and how do I really know what it is doing. I saw a message telling me that the SW was downloading the Kaspersky Anti-Virus tools. That was completed and now it tells me the anti-virus is running. This has been going on for some time? Will this be like all of the other fixit software I have tried to use where there are no indicators as to whether it is hung up, working or not working? I know my pc is messed up, but it is running in Safe Mode w/networking with the AIO System Rescue running. It has been hours. How long should I wait? And will the system restart with no warning? I would love to see some videos of this thing in action.

  5. Have you used YUMI before? Suggestions on incorporating into a mulitboot like YUMI? I believe I read that I should treat it like a Ubuntu image.

    1. Hi software not recognize sdd on some macbook version 2015 up , but on same macbooks fedora or linux mint work fine any idea?

  6. Maybe I am a dummy and doing something wrong but whenever I insert the USB on my Windows laptop, it always runs UBUNTU. I have not been able to figure out how to use it with my Windows laptop. Sorry.

    1. It may be worth reviewing the project page: which discusses that the toolkit has 2 environments, a liveCD and a Windows Autorun. The toolkit is designed to be used by a qualified technician. There are some people out there saying it is a “cure all for the common man” kind of stuff. If you are not a qualified technician, your mileage may vary on your success rate with the toolkit.

  7. Hi, I noticed the tool kit says 2018 version, is it up to date? Do I need to worry for updates or does the toolkit auto-updates when I run it? Thanks for the hard work

    1. The 2018 version is the latest published version of my toolkit. There are no automatic updates as it is designed for single run use. You can subscribe to my project mailing list to be informed when new updates are released.

      1. The 2018 version downloaded was 2018-01-02 which is based on Lubuntu 2016.
        I have an ASSUS ROG STRIX X570-F GAMING motherboard which uses thee AMD 570 chipset. This means temperatures are not read by sensors-detect. I don’t like running stress tests without knowing the CVPU temperature.
        I’m told these will be in kernel 5.4.
        Will there be an update to cover this?

  8. Hi Paul! Congratulations for this work!

    Do you know how I can load AMD RAID driver in the flash drive? If I boot from USB, the utilities cannot see my internal drives.

    Thanks in advanced.

    1. For the 2018 version of my toolkit, I’d look into using AMD fakeraid with Ubuntu 16.04 LTS and dmraid. I include dmraid in the Linux build, but it may not have all or the latest modules needed to interact with all fakeraid setups.

  9. Hi Paul! Congratulations on a brilliant programme that I’ve been using for several years! I have one query – if I pop it on first thing, and leave it, sometimes when I return, it has stopped with a message in a box saying something like, ‘Error – there was a problem downloading Microsoft Safety Scanner’, or just once it has been, ‘Kaspersky Malware Scanner (or something similar)’, so of course, I have to cancel that for the programme to continue. I do have the Microsoft programme on my PC already (not the Kaspersky), and wonder how I can overcome this problem? Many thanks, Norman.

        1. Ah, yes. I understand the confusion. You are referencing Passmark’s Memtest86, which is different than Memtest86+ bundled with Ubuntu distros. I believe I looked into that one and it may have not allowed me distribution rights.

          “Free” for you as one person to download and use software is not the same as free for me to distribute to hundreds of thousands or millions of people independently of the software maker’s knowledge or control.

  10. Hi,

    I just downloaded your toolkit and I’m currently trying to recover and backup data from a computer that doesn’t boot anymore due to this automatic repair loop – how do I do that though? I booted your toolkit through my usb, found my drive but how do I transfer everything to my external drive? I don’t wanna mess anything up so yeah..

    If everything works out I owe you everything in the world man!

    1. It sounds like you need to reach out to a local technician in your area that can assist you with your issue. You do risk losing data if you don’t know what you are doing and don’t have a verified backup.

  11. Also, an issue with your site. I cannot subscribe to the mailing list for updates. It just says “Oops.. Unexpected error occurred.”

  12. I use Proxmox hypervisor, and would like to have a VM with your disk image mounted, so I can use it for secure erasing drives, and cloning/copying. But for some reason it won’t boot in the OVMF UEFI environment QEMU uses. It says it can’t find the CD. If you can’t help, that’s okay. I’m hoping the next version just happens to work, since it seems like a really weird issue.

  13. Hi, is it worth it for me to try using your toolkit on my HP Pavillion 500 PC that died after getting the “blue screen”?

  14. HI Paul,

    Is the Lite version still under development? It seems like it has been a long time since the last update. Thanks for all the hard work on this excellent resource.


  15. I am booting with a USB stick .., When attempting to mount the windows drive an error message stating Windows is in hibernation mode – unable to mount. is there a remedy for this (windows 10)

    1. The reason that’s happening is because Windows 8+ introduced “fast startup”, which basically hibernates the Windows kernel under a normal shutdown to make startup a little quicker; naturally, this would require Windows to lock any drive(s) present prior to shutdown.

      If you restart the machine (or just hold Shift while pressing shutdown from the power menu in Windows), the hibernation doesn’t occur and you shouldn’t get the error message. (You can also disable fast startup if you know where to dig in Windows, but you should probably keep it on because the startup time difference is night and day on some PCs, particularly older ones.)

  16. Hi, Im trying your technician edition. I have only tried to boot in a 27″ Imac 14,2 as of now but it seems that I had no broadcom drivers to the Broadcom BCM43xx 1.0 ( AirPortDriverBrcmNIC-1305.8) airport. Any way to push them there???

    1. As my toolkit live CD portion is based on Ubuntu, you may want to look into the BCM43xx support for Ubuntu. You should be able to install any packages or follow instructions to get it to work, although when you reboot, the Live environment is not persistent so feel free to try and break it and just reboot if you get stuck.

      The specific version of Ubuntu my 2018 toolkit uses is Lubuntu 16.04. Hope that helps!

  17. I was wondering if you’d be able to include the nvme-cli package from mainline Ubuntu’s universe repo. The program’s code appears to be GPLv2 licensed (at least, from what it says on their github page), and it’s helped me out because it lets me securely erase my NVMe drive (something hdparm can’t do). Understandable if you can’t/don’t want to – it’s only a few apt lines away within the toolkit anyway. 🙂

  18. Trying to make a usb boot tool but everytime I try to initiate the process I get an error message that it’s not a valid choice. Must have >700 mb and be formated to fat32 or ntfs. It is a 64gb drive formatted to fat32. Any tips/tricks or workarounds? Running Windows 7 64 bit

      1. Bring in a smaller flash drive in the morning. I’ll test and verify it’s the flash drive size and not another variable causing the error

        1. Have a hp 15 laptop blue screen boot load error for windows 10. Booted legacy in bios to boot from rom drive. The boot repair didn’t fix it. What suggestions can I do to fix this missing boot file? Thanks

  19. Hello everyone,
    I am currently trying to run the fix program from a bootable USB in a Lenovo Yoga 700 laptop. I’ve been trying to repair and boot the machine for quite some time now and it seems that all roads are leading to Win 10 being completely erased from the computer.
    When I run the program, the autostart/autorun/autofix are not available and I also cannot get into the virtual Windows portion. Has anyone else experienced this issue? I can get into the Ubuntu environment just fine. However, I have no autofix functions upon startup.

    1. I recommend you have your computer looked over by a local technician. My toolkit is designed to be used by a technician as most of the tools’ usefulness is designed to be used by the technicians out there that have the training and experience to resolve these kinds of issues.

  20. Hey Paul. I absolutely love the tool…Kudos!
    I saw you’d posted a question about the ‘customize’ tools people have been using & am curious about more myself…but these are the initial one’s I’ve installed and tested successfully:
    – ‘DISM++’ ver. 10.1.1000.80 (great tool)
    – Portable DML (Driver Magician Lite)
    – Rufus 3.3
    – Wireless Key View (Nirsoft)

  21. Hi,
    thank You for creating and sharing AiO Toolkit, basically it can be used in two enviroinments (livecd/Linux and autorun/Windows), so it could be pretty much the universal toolkit. Although I have some minor issues with autorun method in Windows 7.
    Most of the problems are related to either running AiO-SRT.exe and/or starting some basic tools (mostly hardware diagnostics). A few things I noticed:
    – something in the Toolkit automatically sets Windows power plan to High Performance, after closing AiO previous power plan has to be set manually;
    – also there are changes to autostart behavior of external drives (I guess AiO restores defaults?);
    – time/timezone issues, AiO restores default time on windows clock (although it doesn’t happen every time AiO is used, it might be related to internet connection);
    – ip of the pc/network card is changing, its particularly annoying because it makes a mess until manually making changes in firewall;
    – there’s also this thing (sometimes useful, sometimes not) – after exiting AiO, the device (USB stick in my case) is being unmounted/ejected.
    I belive some of these issues are configureable and corresponding functions could be made optional. For example – I can see the reason behind setting some Windows values to defaults, but many times there’s simply no need for that.
    Sadly, I don’t have much experience, so I can’t turn off these auto mechanisms in Your Toolkit by myself (or maybe I can, just don’t know how).
    Initially I thought that the cause was Auto-Fix Utility section, but as it turns out it wasn’t the case (every checkbox unticked and I’m still having some of those issues).
    Could You maybe give me some advice or possible solutions to above mentioned issues?
    I found one related issue in Community Support – post from june 8, 2017 by Tristan Roberts, he says that his drives are showing up really slow, it’s obviously related to Windows power plan: hdd turn-off function…
    Sorry for possible typos and for this not-very-positive post, I hope You will have time to answer and clarify at least some of the issues.
    I really like the idea behind Your Toolbox, thank You and wish You well.
    Best Regards

    1. Answering questions, rapid-fire:
      – My toolkit doesn’t alter Windows Power Plan settings. Perhaps one of the downloaded tools changes Windows behavior.
      – My toolkit does not alter the boot order unless you run the third party utility “Boot Repair” on linux live boot, that might do something like that.
      – Time in linux is default to GMT, Windows uses local time. This causes an issue when booting linux, then Windows if you don’t have NTP + time zone set.
      – Unmount/eject is by design. This is to auto-eject the CD tray or auto unmount the USB to prevent corruption as most tech tasks require a reboot. It speeds up repeat usage and not forgetting CDs in computers in higher volume environments.

      1. Thanks for the response, I belive now, that those issues are strictly on “my end”. What do I mean – Your Toolbox is by design “Your” Toolbox, I just thought that if You are considering making some commercial versions, support etc., maybe there are kind of hidden settings for customizing functions and behaviors (like that last “issue” with auto-eject, I agree that it is useful in many situations, but in my case not always – I added a few portable applications on the same flash drive, now running them and AiO-SRT.exe requires pre-planning – what tools to use when).

        Btw. when I wrote “changes to autostart behavior of external drives” I meant that there are changes to USB drives (in my case) in Windows (not boot), i belive that these changes are connected to Windows Shell, therefore to Power Plans. It is well known that High Performance Power Plan is most reliable, so I understand why some tools in Your toolbox are auto-changing to this particular Power Plan, although it would be nice if after quitting the tool the Power Plan could change back to previous setting.
        Another thing was ip changing issue, I investigated further and that wasn’t exactly the case, just some programs start using different than usual ports to access internet (might it be connected to one of Your auto-fixes – Reset TCP/IP & Winsock?).

        I’m just presenting my own view at those issues, I didn’t really expect You to adress them like You did, so thanks again. I probably don’t have necessary knowledge to use even half of the tools in Your AiO (dealing with home pc’s of family and friends, so I’m using Your Toolbox mostly for diagnostics purposes, not really repairing).
        If I can suggest something – for me a basic info before starting any tool/utility would make much more “user-friendly” (lack of a better word) experience. Again – it’s Your Toolbox, so You know exactly how every tool works and what it does, I myself would also like to know these things (some utilities run semi stand-alone, and these have their own “about” sections, but some are just click-execute, or both – like “hard drive diagnostics” which runs gsmartcontrol, a few read/write tests and schedules chkdsk after reebot…), I would like to know what will happen if I run particular utility from AiO-SRT.exe.
        For example buit-in readme would be useful, it’s just a suggestion, You could say “if You don’t know/don’t remember what it does don’t click at it”, although I’ve been searching Your site and don’t see any info about actions that are executed by clicking on above mentioned “hard drive diagnostics”, so it’s not possible to know what this utility will do before executing it.

        I don’t mean no harm with my reply, You are doing a good work, thank You again for sharing Your own Toolbox.
        Best Regards

  22. FYI: When trying to install and run MalwareBytes I get a mbam.exe – OPENGL32.dll missing error, so I can’t run mbam to disinfect an internal hdd.

  23. Love the tool, Any chance an WinPE is in the works? its hard to find legitimate and reliable tools nowadays,

  24. Wonderful toolkit, thanks!!
    Is the widget also available standalone? I’d like to use it without using the toolkit 🙂

  25. Would 1000% use this for all my needs if I could, except for one very glaring bug I see when using the latest toolkit – the integrated Clonezilla build doesn’t have support for encrypting backups. Is that an implementation problem on your end or just a general problem on non-exclusively Clonezilla builds? Also, is there a way to get it to work on these builds?

    Thanks for making this – it’s helped me out quite a bit this year.

    1. Good to know, Chris.

      I will keep this in mind for the next build.

      I am not sure if encryption on Clonezilla requires a write-able environment in Ubuntu, but that could be something. It could also be a versioning bug in Clonzilla as my build locks all the software versions in at build time.

  26. I really like this ,clean with no bloat ,connects easily to my mobile dongle and uses very lttle memory + s ome useful tools.

    Make a new version that is installable 🙂

    1. I don’t have any plans for install-able or persistent file systems. I get the request often, but it is out of scope of the project and is quite difficult to maintain control over all of the tools as stuff gets updated and changed.

      Also, my file validation will no longer function against a changed/updated environment. Everything gets updated in one fell swoop during a new version release and is tested at great length in many environments to make sure that the release is stable.

      I do not have the resources to maintain a living operating system which is why the use case for my toolkit is “boot it, get in, repair, get out” or “run Windows Autorun tool once”.

    1. Good to know. I can look into this with the next version update. I have been releasing about once per year, so next year’s version should have a 2018 LTS Lubuntu base instead of 2016.

  27. When I try to boot to the liveCD lubuntu, I get the error: “unable to find medium containing live file system”.

    I wrote the ISO to a 128gb USB drive using Rufus.

    Any Thoughts?

    1. Rufus is not the official supported method of creating a USB, you will have to contact the creator of that software to troubleshoot. I have created a tutorial for the official supported USB creation method and also provide prepared USB that can be ordered from the project page.

      For the tutorial covering the official supported USB creation method:
      – Go to the project page:
      – FAQ & Tutorials
      – (Video) How do I make the USB flash drive version?

  28. Hello, i have try to boot from cd and after i choose from the menu i get an error.
    “0.238858 Error Parsing PCC subspaces frpm PCCT” then the lbuntu logo show for like 5min and then the display turn black. Wath can be wrong?

    Best Regards Markus

  29. Strange problem! I’ve created a live USB but on booting from it, it gets past the initial selection and languages screens, loads lubuntu but then asks for a login and password… any ideas why? This is the latest version from your website (2018-01-02). I’ve used a 2017 version previously and that just used to load straight into the Linux GUI after the initial stage.

    1. I get very few of this kind of feedback, like 3 per year. It is usually one of the following cases:
      – Something wrong with the PC during bootup
      – Bad ISO/USB, need to redownload

      I believe the default Lubuntu login is lubuntu/lubuntu.

      1. Thanks for the snappy response! I tried it on another system and seemed to work. Will attempt a re-download and re-image. Thanks once again.

  30. I’m trying to create a super rescue multiboot USB with YUMI. I had issues figuring out the correct distribution to install the ISO with. To save everyone else time, use “Try Unlisted ISO (GRUB Partition 4)”. It worked like a charm

    1. Hello and thank you for checking out my toolkit. This specific question is best left to the maker of the tool nwipe.

      Yes, you can wipe SSDs with traditional wipe methods, such as nwipe, but there are better ways to wipe SSDs. The reason for traditional multi-pass wipe algorithms is because of how traditional spinning disks store data magnetically and there is a physical magnetic trace leftover even after the sector is re-written. SSDs do not store data magnetically and a multi-pass algorithm can unnecessarily thrash the NAND cells.

      You may want to lookup how to use hdparm, TRIM, or ATA Secure Erase for SSDs. Most of those tools are included in my toolkit, however, this Community Support is only about how to use the toolkit itself and not educating people how to fix (or wipe) computers. I can point you to the tools, but I don’t have time to educate the world about how to be a technician, there are schools and certifications for that. 🙂

      Hope that helps point you in the right direction.

  31. Thanks for the toolkit. I just discovered it the other day when looking for an alternative to the live distro including nwipe and SMART data checking that I had been using.

    I have a question about the nwipe version you have chosen to include with the latest release. nwipe has released newer versions up to 0.24 most recently, however you have version 0.17 included in your 2018-01-02 toolkit.

    Here’s the thing, though. I have actually been running on nwipe version 0.14 for years, and it has worked well because 0.14 logs the device serial numbers , whereas version 0.17 does not, nor does 0.24. 0.21 was just broken when I tried it.

    So what I’m trying to figure out is if there is a toolkit like this anywhere that is running the “best” version of nwipe out there. I haven’t tried every version of it yet to determine what I would think that to be, but I can’t work with a version that doesn’t log the device serial numbers. That is a requirement, which is why I’ve been using such an old version for so long.

    If you’re interested in entertaining changing the nwipe version, I would be happy to do some of the leg work by trying each release and giving my own feedback on it. Thank you so much for your time.

    1. Thank you for checking out my toolkit. My toolkit relies on the repositories for the official Ubuntu release of nwipe.

      As of the 2018 toolkit version, the latest LTS version of Ubuntu was 16.04. The best way to go about what you are asking would be to contact the developer of nwipe and ask them for that requirement. Eventually all of the software sources and Linux distros will adopt the changes as they update.

      This may be a good starting point for you:

      1. Haha. That’s the exact page that brought me here, actually. I’ve been participating in some discussions over on their Github project page for a while discussing features and bugs.

        So essantially, whichever version of nwipe is in the latest Ubuntu LTS release will be what you include in AIO-SRT?

        1. Oh yeah, I had one other question. Does your tool have a persistence feature? I’m having a hard time finding that answer anywhere. I was considering trying to change the nwipe version myself on my USB install, but if I can’t save the changes to the system afterward, that would be pointless.

          Thanks again.

          1. Lots of good questions, hopefully this answers them for ya:

            The toolkit doesn’t support persistence at this time since it is pre-packed and loaded using the squash.fs filesystem. There are no plans to officially support persistence, however Ubuntu has a great guide for getting it setup.

            Persistence would make things like file integrity checking on both the boot menu as well as Windows Autorun difficult. One of the integrity checks (the cloud icon one) for Windows Autorun pulls down the latest file checksums for the ISO file as originally published and released from the web. Also, the “Removable Device” format using FAT32 doesn’t officially support multi-partition USB drives as far as I am aware.

            Also, yes, for the sake of my sanity of verifying bugs for every single piece of software, I choose the most recent stable versions as of the ISO preparation date. Ubuntu does a great job with LTS versions of keeping bugs to a minimum so that apps work in as many configurations as possible as stable as possible. With the Windows apps, I update them on a final push before publishing a toolkit version.

  32. Hello, I am new to ISO’s so forgive me for the learning curve. I successfully created the AiO-SRT flash drive with no problem. I also want to make a live CD but not sure how to proceed. I have the AiO-SRT iso on my computer. What are the next steps to create a bootable CD and then install AiO-SRT on it? Thanks in advance.

    1. Thank you for checking out my toolkit. You may want to Google “Burn ISO to CD”.

      I think most recent versions of Windows give you a burn to disc option when you right click on the ISO.

  33. There is a problem with the USB drivers loading. I get to the desktop, but the mouse & keyboard do not respond. I’m booting from a CD.
    I see during booting a ton of USB5/4 device descriptor & read/64 error -32 lines stating unable to enumerate, not accepting address xxx

    I have run into these errors with 1 or 2 other bootable programs, thou most bootable programs work fine.

    I have a UEFI MB, but I’m running it in BIOS mode if that matters.

    1. If you are having issues with multiple boot environments, I might look into the underlying hardware more than a specific toolkit. It sounds like more environments than just my toolkit are complaining about USB on your system.

      This is a strange issue and I have not personally encountered this before. It is possible if the PC (and/or USB chipset) is newer than 2016 that there’s something not quite right with the USB support in Lubuntu 16.04.3 LTS (or other boot environments you mentioned).

      By the time I release my next version, 18.04 Ubuntu LTS should be released and we will have a newer platform for the LiveCD environment. I refuse to use anything other than LTS for production and serious repair tools.

      I am curious to see if anyone else reports or replies with this kind of issue. Thanks for letting me know!

  34. Hi, first of all, thank you for this useful tool. I´ve used it in quite a few PCs with greats results. However, I recently got an issue in an old notebook, when I try to run it from a live USB the following message comes up:
    “This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot”.
    The PC has an Intel Atom N270, 32 bit CPU, 2GB of RAM, and is running Windows 7 Ultimate as primary OS. Is there any solution to this problem?

  35. Hello — Do you recommend running your toolkit (I have the lite version) as a part of routine maintenance, or is it solely for troubleshooting problems? My antivirus (Microsoft Security Essentials) runs once a day, and about once a week I run Malwarebytes and BleachBit. Would it be useful to add in your System Rescue kit to my routine? I’m running Win7/64 on an aging laptop.

    1. None of the utilities in my toolkit are so aggressive as to cause issues if run too often. (No registry “cleaners” for example).

      For a well maintained system, it might be useful to run once per year or every 6 months. It’s really designed as a stop gap when deciding if a technician needs to get involved with the system repair. Run the toolkit first, if there’s still issues, definitely call a technician because it does almost all of the basics.

      I typically do a tune-up to my PC when I “start to feel it”. Sluggish, taking longer to boot or load apps, etc. For most of my paying clients, this lands in the every 6-12 months range.

  36. Boot problems on my Dell XPS 15. Start to boot, but then hangs with the Lubuntu logo. I fixed my problem with another Tool disc, but I just though that you might want to know.

    1. Thanks for letting me know. Do you know if you were booting UEFI or BIOS? Also CD or USB?

      To prevent issues with burning/creating bad media here are some steps I use when I build official discs that people order from me:
      – Use known good media for CDs (Verbatim, Memorex, etc). Some cheap media will not recognize in all CD/DVD drives.
      – Verify disc after burning, most burning software has this option, but not turned on by default
      – Use known good media for USBs (SanDisk, PNY, Transcend, Kingston, etc). Cheap USBs are known to cause I/O issues
      – Verify integrity of USB creation from the General tab in Autorun after creating USB

  37. Is it possible to turn off the creation of the internet shortcut on the desktop when you close the application?

    1. Are you asking for free software you are using to not be credited back to the software creator? Think about it.

      There is a small possibility that I might offer a paid branded option for IT shops out there to rebrand my software and drop their own links, website information, etc. I have no plans at the moment to begin that process though.

      Getting my name, website, and information out there is one of the ways I am allowing people to use my software for free.

  38. Great project, thanks for all your work on this. I’m wondering how difficult it would be to include support for bitlocker encrypted drives via dislocker? Likely you’ve already considered modifying the live CD to either have some persistence or include the libraries by default, I’m trying to wade through the documentation to see how to include by default. I can get drives mounted and unencrypted but have to install several libraries to get dislocker compiled the first time booting on new machine. Thanks again for your efforts and any hints would be appreciated!

    1. I have looked into dislocker before. While I am able to use linux and script just fine, the goal of my toolkit is simplicity and generalization for the masses. There are just too many hacky steps to include the utility in LiveCD when Windows already includes utilities to work with BitLocker natively on the installation media.

      BitLocker is just enough of an outlying case that I can’t really justify putting it on without something polished to make it useful for the masses. Most corporations that rely on bitlocker should also have an in-house procedure for working with bitlocker encryption and recovery.

      It’s one of those tools that if you need it, you search it out specifically, and you plan for the “just in case” scenario. Also, backups are important. Any data recovery specialist shops that deal with this also have in-house tools and wouldn’t reach for my generalized toolkit, I hope.

      This was almost the case with chntpw. It’s a bit hacky to use, which is fine for me, but resetting Windows passwords is way more common than BitLocker recovery without backups.

  39. I may be missing something or looking in the wrong place (highly likely!) but I have been unable to find a temperature monitor. A colleague advised that his laptop seems to be overheating and the fan kicks in (as it should) during normal operation but he says it is like a jet taking off. I have run the CPU stress test application for 15 or 20 minutes and have been unable to get the fan to make the fan make as much noise as he says it does. Whilst the widgets on the right hand side of the screen tell me how much load the CPU is experiencing, it would be helpful to have a temperature monitor so that I can show him that everything is within normal limits. Are there any plans to implement such a feature or is this one that has been considered and disregarded? Kudos on useful piece of kit though.

    1. On the LiveCD part of the 2017 toolkit version the temp gauge needed to be added to the panel manually. I made a tutorial about how to diagnose PCs with my toolkit that shows how to do this. Windows Autorun CPU stress test automatically runs HWMonitor which shows gauges.

      Starting with 2018 version, “CPU Stress Test” is renamed “mprime” and autoruns a sensors monitor on the LiveCD portion. HWMonitor is still used during Prime95 on the Autorun side. It sounds like you are running the older version.

  40. I see there is a checkbox next to the automatic mode under “autoFIX”. How does one save this setting to “off” so that it doesnt run automatically?

    Ive unchecked it and closed and reopened the program but it reverts back to default.

    1. Just in case anyone else is wondering as well. The toolkit customization only works with writable media.

      autoFIX customization is also only saved when it is run. So if you select options, close and reopen, it will just load last settings. You can also look in the custom.ini file inside “extras\custom” on the toolkit to see how the options are stored.

  41. I just downloaded the ISO of the all in one toolkit and burned it to a CD for testing. When I insert the CD into a Windows 7 machine and double-click on AIO-SRT.exe, I get a warning that the file contains a virus. The exact message is: “Operation did not complete successfully because the file contains a virus.” I am now concerned about evaluating the toolkit further. Anti-virus software installed is Avast Business CloudCare (formerly AVG CloudCare). Any thoughts?

    1. With any new software, not just mine, I would recommend evaluation on a non-critical PC. This can be done in a virtual machine or “project PC”.

      To address your question directly, my toolkit doesn’t have the funds to pay for whitelisting for all antivirus software out there, so it relies on reports of false positive from the community of each antivirus. This version was just released this past week, so it probably doesn’t have that “false positive” flagging done yet. I just had a campaign to get unblocked by MalwareBytes, which was successful thanks to the toolkit community.

      If it helps, you can check out some of the reviews on my references page written by other folks in many languages:

      Some notable places off the top of my head that reference the toolkit include: LifeHacker, MajorGeeks, GHacks, Navigaweb, Chip Online, Hitek, TheWindowsClub.

      I will update my FAQ entry on antivirus alerts for everyone.

  42. It appears Microsoft’s ‘Create a Recovery Drive’ is the bane of my existence. I was able to run it normally on one PC, had a whole bunch of problems on another (but finally got it to work), now the 3rd one has me stymied. The message I get is “We can’t create a recovery drive on this PC. Some required files are missing. To troubleshoot problems when your PC can’t start, use your Windows installation disc or media.”

    I’ve run Windows Update, SFC and DISM and they didn’t do anything to fix this issue. Windows, of course, gives me no clue as to which ‘required files’ are missing and the PC otherwise works fine. It’s a Cyperpower PC with AMD Ryzen 1700x processor on an MSI Bazooka motherboard. Windows 10 Home was originally on the HDD, but has been installed on a SSD and runs from there.

    I note there are 3rd party utilities to create bootable Windows drives, but I’m leery of using one without a recommendation or reference from a trusted source.

    Here are my questions:

    1) Does your AIO-SRT have a utility to create a bootable USB flash drive?

    2) If not, is there a 3rd party utility you’d recommend?

    Thanks in advance.

    1. My toolkit can create a bootable USB version of itself (Lubuntu 16.04 LiveCD base), and contains a program called Rufus that can create bootable USBs from ISOs. Although, I think your question is about creating bootable Windows environments which I do not have the legal rights to, nor does pretty much anyone else that I know of except Microsoft.

      Missing Microsoft Windows core files can’t (and shouldn’t) come from anywhere else except Microsoft Windows installation media, otherwise you are right to be skeptical of “alternative” files not coming from official Microsoft sources. There are no utilities that I know of that can fabricate or replace missing core Windows files except official Microsoft Windows installation media.

      My toolkit’s live environment can be used to attempt data recovery or transfer data in the event of a core Windows installation failure, but if you don’t know what you are doing, I highly recommend using a data recovery specialist if you value the data at all. It sounds like your system is still running, however. Keep good backups!

Leave a Reply

Your email address will not be published. Required fields are marked *